Back to overview
Degraded

Some digital gift emails are not sending

Apr 30, 2025 at 3:43pm UTC
Affected services
Toggle Shops

Resolved
Apr 30, 2025 at 4:49pm UTC

This has now been resolved and emails are sending as expected.

Created
Apr 30, 2025 at 3:43pm UTC

We are experiencing an issue where some gift emails are not being sent to the recipient. We are working on resolving the issue.